Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 19, 2024 - 16:00 UTC
Scheduled
Dear Customers,
Please note that on Tuesday, 19 November we will be undergoing maintenance to bring you the newest version of TIS Cash Forecasting.
During this period, you will still be able to access the platform since this upgrade should have no or limited impact on the availability of the application.
If you need immediate assistance, please contact your Customer Success representative.
Posted Nov 08, 2024 - 10:28 UTC
This scheduled maintenance affected: Cash Forecasting.