Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 05, 2026 - 16:00 UTC
Scheduled
Dear Customers,
We would like to inform you that we have scheduled a technical maintenance upgrade for Friday, June 5 from 17:00–18:00 CET.
During this maintenance, our team will perform a system update to improve overall stability and reliability. To ensure the upgrade is completed safely, the application will be temporarily unavailable for a few minutes during the process.
We appreciate your understanding and patience.
If you have any questions, please feel free to reach out.
TIS Dev Team
Posted May 28, 2026 - 12:02 UTC
This scheduled maintenance affected: Cash Forecasting.